re = /^http(s?)\:\/\/[^\s\/$.?#*]+\.[^\s\/$.?#*]+(\.[^\s\/$.?#*]+)*$/m
str = 'https://example.org
http://a.a
http://123.123.123.123:8074'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end