#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Za-z]{8}(\d+.\d{2})"
Local $sString = "abcdefgh30.00000" & @CRLF & _
"abcdefgh300.0000" & @CRLF & _
"abcdefgh3000.00" & @CRLF & _
"abcdefgh3.00000" & @CRLF & _
"abcdefgh0.05000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")