use strict;
my $str = 'abcdefgh30.00000
abcdefgh300.0000
abcdefgh3000.00
abcdefgh3.00000
abcdefgh0.05000';
my $regex = qr/[A-Za-z]{8}(\d+.\d{2})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}