// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Za-z]{8}(\d+.\d{2})").unwrap();
let string = "abcdefgh30.00000
abcdefgh300.0000
abcdefgh3000.00
abcdefgh3.00000
abcdefgh0.05000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}