const regex = /^(Plugins(?!.*\bdns\b).*)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(Plugins(?!.*\\bdns\\b).*)$', 'mg')
const str = `Plugins = none, of,the, required_ones
Plugins=still,missing,here
Plugins = one,other,dns,else
Plugins= some,where,dns,in,there
Plugins=the,very,last,thing,dns`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}