$re = '/^(?!.*(?<!\S)opt3(?!\S))filename\.txt/m';
$str = 'filename.txt opt1 opt2 opt4 testopt3test
filename.txt opt1 opt2 opt4 $opt3#
filename.txt opt1 opt2 opt4 opt3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);