// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi).*(hello.+you).*").unwrap();
let string = "aaaHello will get match with the last you, you see?
Also this hello won't get selected, but the last one will, hello you!
Here this hello you combo won't get selected, but the last will, hello, you see?
Btw, you might wondering why do you see blue on everything, welp, that's all I can do, if theres no he-llo you combination it won't match, otherwise it matches everything as group 0, and the word you need as group 1. (so yea just take data group 1 and it's gud)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}