// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^[ \t]*("[^"]*")"#).unwrap();
let string = "[
{
\"group\": \"Simple\",
\"name\": \"Simple\",
\"category name\": \"Apps\",
\"icon\": \"Simple.svg\",
\"paths\": [
{
\"path\": \"notepad.exe\"
}
]
},
// some comment here
{
\"group\": \"Simple\",
\"name\": \"Simple\",
\"category name\": \"Simple\",
\"icon\": \"Simple.svg\"
\"paths\": [
{
\"path\": \"notepad\",
\"args\": \"notepad.py\"
},
{
\"path\": \"run.exe\",
}
]
}
]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}