# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^.*)(DEL*\s((LA|LOS|LAS)\s)?\w+)(.*,)/\2 /g;t' <<< "POSADAS DE RIO,FRANCISCO ANIBAL"