$re = '/(^.*)(DEL*\s((LA|LOS|LAS)\s)?\w+)(.*,)/';
$str = 'POSADAS DE RIO,FRANCISCO ANIBAL';
$subst = "\2 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;