using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[A-Z])(?!.*_).+";
string input = @"FALSE:
example-chocolate-easter-egg-170g_349-85428671-ACCESSIBLEEASTEREGG
chocolate-easter-egg-170g349-85428671-accessibleeasteregg
TRUE:
example-chocolate-easter-egg-170g349-85428671-ACCESSIBLEEASTEREGG
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}