re = /^(?=.*[A-Z])(?!.*_).+/m
str = 'FALSE:
example-chocolate-easter-egg-170g_349-85428671-ACCESSIBLEEASTEREGG
chocolate-easter-egg-170g349-85428671-accessibleeasteregg
TRUE:
example-chocolate-easter-egg-170g349-85428671-ACCESSIBLEEASTEREGG
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end