import Foundation
let pattern = #"^(?=.*[A-Z])(?!.*_).+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
FALSE:
example-chocolate-easter-egg-170g_349-85428671-ACCESSIBLEEASTEREGG
chocolate-easter-egg-170g349-85428671-accessibleeasteregg
TRUE:
example-chocolate-easter-egg-170g349-85428671-ACCESSIBLEEASTEREGG
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)