const regex = /^[a-zA-Z0-9](?:[a-zA-Z0-9 _-]*[a-zA-Z0-9])?\.[a-zA-Z0-9_-]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9](?:[a-zA-Z0-9 _-]*[a-zA-Z0-9])?\\.[a-zA-Z0-9_-]+$', 'gm')
const str = `## BELOW SHOULD MATCH
web.config
httpd.conf
test.txt
1.1
my long file name.txt
## BELOW SHOULD NOT MATCH
æøå.txt
hosts
.gitignore
.htaccess
test.t xt
web.config.txt
httpd.conf
\\httpd.conf
/httpd.conf
test.zip.txt
sdasdf.doc
sdas_-df.doc
sdas/df.doc
sd\\asdf.doc
hai cats or dogs
.txt
awdsf.txt.txt.doc.docx
1.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}