#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)(?<=[ \t])-?" & @CRLF & _
"(?:" & @CRLF & _
"(?:" & @CRLF & _
" \d" & @CRLF & _
" |[1-9]\d+" & @CRLF & _
" |[1-9]\d*\.\d{1,3}(?<!0)" & @CRLF & _
" |\.\d{1,3}(?<!0)" & @CRLF & _
")|(?:" & @CRLF & _
" (\.0*)0" & @CRLF & _
" |(0+)\.\d{0,2}[1-9]" & @CRLF & _
" |(0+)(?:0|[1-9]\d*)\.?\d*" & @CRLF & _
" |\d+(\.0*)" & @CRLF & _
" |\d*\.(?:[1-9]|\d[1-9])?(0+)" & @CRLF & _
" |\d*\.\d{3}(\d+)" & @CRLF & _
")" & @CRLF & _
")" & @CRLF & _
"(?=[ \t]|$)[ \t]?"
Local $sString = "Valid:" & @CRLF & _
"* Integers" & @CRLF & _
" 0 1 10 123" & @CRLF & _
" -0 -1 -10 -123" & @CRLF & _
"* Floats <1, without leading zero, (1<=precision<=3)" & @CRLF & _
" .1 .01 .001 .12 .123" & @CRLF & _
" -.1 -.01 -.001 -.12 -.123" & @CRLF & _
"* Floats >1, (1<=precision<=3)" & @CRLF & _
" 1.1 1.01 1.001 1.12 1.123 12.1 12.12 12.123 123.1 123.12 123.123" & @CRLF & _
" -1.1 -1.01 -1.001 -1.12 -1.123 -12.1 -12.12 -12.123 -123.1 -123.12 -123.123" & @CRLF & _
"" & @CRLF & _
"Invalid (in order of capture):" & @CRLF & _
"* [1] Zero as float with only trailing zeros" & @CRLF & _
" .0 .00 .000" & @CRLF & _
" -.0 -.00 -.000" & @CRLF & _
"* [2] Floats <1, with leading zero" & @CRLF & _
" 0.1 0.01 0.001 0.12 0.123" & @CRLF & _
" -0.1 -0.01 -0.001 -0.12 -0.123" & @CRLF & _
"* [3] Integers with leading zeros" & @CRLF & _
" 00 01 012 0123 000 001 0012 00123 0000 0001 00012 000123" & @CRLF & _
" -00 -01 -012 -0123 -000 -001 -0012 -00123 -0000 -0001 -00012 -000123" & @CRLF & _
"* [4] Integers as float ('fake floats')" & @CRLF & _
" 0. 1. 12. 123." & @CRLF & _
" 0.0 0.00 0.000 0.0000" & @CRLF & _
" 1.0 1.00 1.000" & @CRLF & _
" -0. -1. -12. -123." & @CRLF & _
" -0.0 -0.00 -0.000 -0.0000" & @CRLF & _
" -1.0 -1.00 -1.000" & @CRLF & _
"* [5] Floats with trailing zeros" & @CRLF & _
" 1.10 1.100 1.120 .10 .100 .120" & @CRLF & _
" -1.10 -1.100 -1.120 -.10 -.100 -.120" & @CRLF & _
"* [6] Any float with precision >3" & @CRLF & _
" 0.0001 0.0012 0.0123 0.1234" & @CRLF & _
" 1.0001 1.0012 1.0123 1.1234" & @CRLF & _
" 10.0001 10.0012 10.0123 10.1234" & @CRLF & _
" 100.0001 100.0012 100.0123 100.1234" & @CRLF & _
" -0.0001 -0.0012 -0.0123 -0.1234" & @CRLF & _
" -1.0001 -1.0012 -1.0123 -1.1234" & @CRLF & _
" -10.0001 -10.0012 -10.0123 -10.1234" & @CRLF & _
" -100.0001 -100.0012 -100.0123 -100.1234" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")