use strict;
my $str = 'Valid:
* Integers
0 1 10 123
-0 -1 -10 -123
* Floats <1, without leading zero, (1<=precision<=3)
.1 .01 .001 .12 .123
-.1 -.01 -.001 -.12 -.123
* Floats >1, (1<=precision<=3)
1.1 1.01 1.001 1.12 1.123 12.1 12.12 12.123 123.1 123.12 123.123
-1.1 -1.01 -1.001 -1.12 -1.123 -12.1 -12.12 -12.123 -123.1 -123.12 -123.123
Invalid (in order of capture):
* [1] Zero as float with only trailing zeros
.0 .00 .000
-.0 -.00 -.000
* [2] Floats <1, with leading zero
0.1 0.01 0.001 0.12 0.123
-0.1 -0.01 -0.001 -0.12 -0.123
* [3] Integers with leading zeros
00 01 012 0123 000 001 0012 00123 0000 0001 00012 000123
-00 -01 -012 -0123 -000 -001 -0012 -00123 -0000 -0001 -00012 -000123
* [4] Integers as float (\'fake floats\')
0. 1. 12. 123.
0.0 0.00 0.000 0.0000
1.0 1.00 1.000
-0. -1. -12. -123.
-0.0 -0.00 -0.000 -0.0000
-1.0 -1.00 -1.000
* [5] Floats with trailing zeros
1.10 1.100 1.120 .10 .100 .120
-1.10 -1.100 -1.120 -.10 -.100 -.120
* [6] Any float with precision >3
0.0001 0.0012 0.0123 0.1234
1.0001 1.0012 1.0123 1.1234
10.0001 10.0012 10.0123 10.1234
100.0001 100.0012 100.0123 100.1234
-0.0001 -0.0012 -0.0123 -0.1234
-1.0001 -1.0012 -1.0123 -1.1234
-10.0001 -10.0012 -10.0123 -10.1234
-100.0001 -100.0012 -100.0123 -100.1234
';
my $regex = qr/(?<=[ \t])-?
(?:
(?:
\d
|[1-9]\d+
|[1-9]\d*\.\d{1,3}(?<!0)
|\.\d{1,3}(?<!0)
)|(?:
(\.0*)0
|(0+)\.\d{0,2}[1-9]
|(0+)(?:0|[1-9]\d*)\.?\d*
|\d+(\.0*)
|\d*\.(?:[1-9]|\d[1-9])?(0+)
|\d*\.\d{3}(\d+)
)
)
(?=[ \t]|$)[ \t]?/xmp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}