re = /^(?:.(?=.*\n(\1?.)))*?X.*\n\1?(.)/m
str = 'X.........
..........
...X......
..........
..X.......
..........
.......X..
..........
.........X
..........'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end