const regex = new RegExp('"pack_id": "(.*)"', 'img')
const str = `I/okhttp.OkHttpClient: {
"route_state": "give_packs",
"shelves": [
{
"pack_id": "100142009300S2T1599432189",
"shelf": "13",
"total_goods": 2,
"pack_state": "new"
},
{
"pack_id": "100143022336S5T1599502063",
"shelf": "21",
"total_goods": 5,
"pack_state": "new"
},
{
"pack_id": "100143367911S2T1599558724",
"shelf": "6",
"total_goods": 2,
"pack_state": "new"
},
{
"pack_id": "100143699532S5T1599568344",
"shelf": "30",
"total_goods": 5,
"pack_state": "new"
},
{
"pack_id": "50127475503S1T1599567324",
"shelf": "10",
"total_goods": 1,
"pack_state": "new"
},
{
"pack_id": "100143773834S4T1599570622",
"shelf": "36",
"total_goods": 4,
"pack_state": "new"
},
{
"pack_id": "100143789121S1T1599571959",
"shelf": "4",
"total_goods": 1,
"pack_state": "new"
},
{
"pack_id": "100143772313S1T1599587841",
"shelf": "29",
"total_goods": 1,
"pack_state": "new"
},
{
"pack_id": "50127216356S2T1599555765",
"shelf": "16",
"total_goods": 2,
"pack_state": "new"
},
{
"pack_id": "100143911917S9T1599578036",
"shelf": "28",
"total_goods": 9,
"pack_state": "new"
},
{
"pack_id": "100144040317S3T1599592353",
"shelf": "45",
"total_goods": 3,
"pack_state": "new"
},
{
"pack_id": "50122511688S10T1599216787",
"shelf": "14",
"total_goods": 10,
"pack_state": "new"
},
{
"pack_id": "100143883877S3T1599580528",
"shelf": "18",
"total_goods": 3,
"pack_state": "new"
},
{
"pack_id": "50125998587S5T1599460888",
"shelf": "35",
"total_goods": 5,
"pack_state": "new"
},
{
"pack_id": "100143065694S7T1599505793",
"shelf": "19",
"total_goods": 7,
"pack_state": "new"
},
{
"pack_id": "50126023780S18T1599462088",
"shelf": "23",
"total_goods": 18,
"pack_state": "new"
},
{
"pack_id": "100143257387S1T1599516006",
"shelf": "3",
"total_goods": 1,
"pack_state": "new"
},
{
"pack_id": "100143204003S8T1599513922",
"shelf": "42",
"total_goods": 8,
"pack_state": "new"
},
{
"pack_id": "100143474921S10T1599546590",
"shelf": "33",
"total_goods": 10,
"pack_state": "new"
},
{
"pack_id": "50126884830S5T1599522235",
"shelf": "22",
"total_goods": 5,
"pack_state": "new"
},
{
"pack_id": "100142045579S1T1599431118",
"shelf": "12",
"total_goods": 1,
"pack_state": "new"
}
]
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}