$re = '/^((?!car).)*book.*$/m';
$str = 'this car is a book
this is a book
book car';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);