using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[(error|warn)\]\s+(.+?):(\d+):(?:(\d+):)?\s+(.+)$";
string input = @"[error] C:\Me\MyPath\myFile.scala:18:22: not found: value getaa
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}