#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s+\(\d+(?:\.\d+)?%\)"
Local $sString = "orange (43%), blue (2.1) (55%), red yellow (77%), red-blue (80%)" & @CRLF & _
"orange, blue (2.1), red yellow, red-blue"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)