use strict;
my $str = 'orange (43%), blue (2.1) (55%), red yellow (77%), red-blue (80%)
orange, blue (2.1), red yellow, red-blue';
my $regex = qr~\s+\(\d+(?:\.\d+)?%\)~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";