use strict;
my $str = 'NetworkManager/system connections/Wired 1.nmconnection:14 address1=10.1.10.71/24,10.1.10.1';
my $regex = qr/\G[^ :]*\K /mp;
my $subst = '\\\\ ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";