re = /([+][359]{3}([ |-])[2]\2[0-9]{3}\2[0-9]{4})\b/m
str = '+359 2 222 2222
+359-2-222-2222
359-2-222-2222, +359/2/222/2222, +359-2 222 2222
+359 2-222-2222, +359-2-222-222, +359-2-222-22222
+359-2-222-2222'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end