# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:export\s+|)(?<key>[[:alnum:]_]+)\s*=\s*((?<quote>[\"'])?(?<val>.*?)\k<quote>?|)$"
test_str = ("DOT_ENV=dotenv\n"
"#DOTENV=dotenv\n"
"DOT_ENV= asdf asf \n"
"DOTENV='dot env'\n"
"DOTENV=\"dot env\"\n"
"DOT_ENV='dotenv'\n"
"DOT_ENV=\"DotEnv\"\n"
"DOTENV=\"Dot\\nEnv\"\n"
"DOTENV=\"{\"Dot\":\"Env\"}\"\n"
"export DOTENV=\"dotenv\"\n"
"DOTENV =\"dot env\"\n"
"DOTENV= \"dot env\"\n"
"DOTENV = \"dot env\"\n"
"DOTENV=\"\"\n"
"DOTENV=\"\\\"\"\n"
"DOTENV=\"DOTENV\"")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.