# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=[^0-9]*[0-9])(?=[^a-z]*[a-z])(?=[^A-Z]*[A-Z])[\x21-\x7e]{8,20}$"
test_str = ("1abcderfggdgf\n"
"sdvhbsdifsdfsdf1\n"
"Ghhuidicbdbuhbdc\n"
"bhdbcdbebvuheY\n"
"uuvvvyuv1G\n"
"1Guhuuuyuyuby\n"
"Y%*&^$^%^(^(GVGVYUKVYTUHBKBUFygyygyg\n\n"
"ebfuiuberiueu23423HHII")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.