(?i)applies the following effective flags to the remainder of the pattern: gmi i modifier: insensitive. Matches without distinguishing uppercase and lowercase letters
Group Lp(?<Lp>\d{1,2}(?![\s\S]*?(Lp\.|Ilość|Cena))) \d{1,2}a digit, repeated between 1 and 2 times
Negative Lookahead(?![\s\S]*?(Lp\.|Ilość|Cena)) *?matches any number of characters from the set below:
\sany whitespace character
\Sany non-whitespace character
Lpthe literal text Lp (case insensitive) \.the literal . (4610 / 568 / 2E16)
Ilośćthe literal text Ilość (case insensitive) Cenathe literal text Cena (case insensitive) \s*any whitespace character, repeated any number of times
Group NazwaProduktu(?<NazwaProduktu>([\S ]*?[\n\r]*){1,3}) Group 4([\S ]*?[\n\r]*){1,3} {1,3}repeats the group contents below between 1 and 3 times:
*?matches any number of characters from the set below:
\Sany non-whitespace character
the literal (3210 / 408 / 2016)
*matches any number of characters from the set below:
\na line-feed (newline) character (ASCII 10)
\ra carriage return (ASCII 13)
\s+any whitespace character, repeated at least once
Group Ilosc(?<Ilosc>([a-z]{3}|\d{1,3}\s*[a-z]{3})) Group 6([a-z]{3}|\d{1,3}\s*[a-z]{3}) {3}matches exactly 3 characters from the set below:
a-zone character from a (9710) to z (12210) (case insensitive)
2nd Alternative\d{1,3}\s*[a-z]{3} \d{1,3}a digit, repeated between 1 and 3 times
\s*any whitespace character, repeated any number of times
{3}matches exactly 3 characters from the set below:
a-zone character from a (9710) to z (12210) (case insensitive)
\s*any whitespace character, repeated any number of times
Group SWW(?<SWW>\s*\d{2}\.\d{2}\.\d{2}.\d{1,2}) \s*any whitespace character, repeated any number of times
\d{2}a digit, repeated exactly 2 times
\.the literal . (4610 / 568 / 2E16)
\d{2}a digit, repeated exactly 2 times
\.the literal . (4610 / 568 / 2E16)
\d{2}a digit, repeated exactly 2 times
.any character (except for line terminators)
\d{1,2}a digit, repeated between 1 and 2 times
\s*any whitespace character, repeated any number of times
Group CenaNetto(?<CenaNetto>(\d{1,3},\d{2}|\d{1,3}\.\d{1,3},\d{2})) Group 9(\d{1,3},\d{2}|\d{1,3}\.\d{1,3},\d{2}) 1st Alternative\d{1,3},\d{2} \d{1,3}a digit, repeated between 1 and 3 times
,the literal , (4410 / 548 / 2C16)
\d{2}a digit, repeated exactly 2 times
2nd Alternative\d{1,3}\.\d{1,3},\d{2} \d{1,3}a digit, repeated between 1 and 3 times
\.the literal . (4610 / 568 / 2E16)
\d{1,3}a digit, repeated between 1 and 3 times
,the literal , (4410 / 548 / 2C16)
\d{2}a digit, repeated exactly 2 times
\s*any whitespace character, repeated any number of times
Group WartoscNetto(?<WartoscNetto>(\d{1,3},\d{2}|\d{1,3}\.\d{1,3},\d{2})) Group 11(\d{1,3},\d{2}|\d{1,3}\.\d{1,3},\d{2}) 1st Alternative\d{1,3},\d{2} 2nd Alternative\d{1,3}\.\d{1,3},\d{2} \s*any whitespace character, repeated any number of times
Group StVAT(?<StVAT>\d{1,2}) \s*any whitespace character, repeated any number of times
Group KwotaVAT(?<KwotaVAT>(\d{1,3},\d{2}|\d{1,3}\.\d{1,3},\d{2})) \s*any whitespace character, repeated any number of times
Group WartoscBrutto(?<WartoscBrutto>(\d{1,3},\d{2}|\d{1,3}\.\d{1,3},\d{2})) \s*any whitespace character, repeated any number of times
Group Waluta(?<Waluta>[a-z]{3}) g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string