$re = '/(^(DHL)((?!@dhl\.com).)*$)|(^(SF\sEXPRESS)((?!@sf-express\.com).)*$)/m';
$str = 'DHL EXPRESS <notice@otherdomain.com>
DHL EXPRESS <notice@dhl.com>
SF EXPRESS <notice@spamdomain.com>
SF EXPRESS <notice@sf-express.com>
Any Email Address <any@emailaddress.com>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);