const regex = /^]d2(?:
01(?P<g01>.{14})|
10(?P<g10>(?:(?!\[GS]).){1,20})(?:\[GS]|$)|
17(?P<g17>.{6})|
21(?P<g21>(?:(?!\[GS]).){1,20})(?:\[GS]|$)
)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^]d2(?:
01(?P<g01>.{14})|
10(?P<g10>(?:(?!\\[GS]).){1,20})(?:\\[GS]|$)|
17(?P<g17>.{6})|
21(?P<g21>(?:(?!\\[GS]).){1,20})(?:\\[GS]|$)
)+$', 'gm')
const str = `]d2010704626096200210KT0BT2204[GS]1726090021RNM5F8CTMMBHZSY7]
]d201070462608682672140097289158930[GS]10101656[GS]17261130`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}