#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(Deathtouch|(Double|First)\sStrike|Flying|Hexproof|(Indestructib|Tramp)le|(Men|Vigil)an?ce|Lifelink|Reach)\sCounter"
Local $sString = "Deathtouch Counter" & @CRLF & _
"Double Strike Counter" & @CRLF & _
"First Strike Counter" & @CRLF & _
"Flying Counter" & @CRLF & _
"Hexproof Counter" & @CRLF & _
"Trample Counter" & @CRLF & _
"Reach Counter" & @CRLF & _
"Menace Counter" & @CRLF & _
"Lifelink Counter" & @CRLF & _
"Indestructible Counter" & @CRLF & _
"Vigilance Counter" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")