$re = '/a\.b\([^()]*\)(?=;)/';
$str = 'a.b();
a.b(param1=1);
a.b(param1=1, param2=2);';
$subst = "\g<0>.c()";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;