import Foundation
let pattern = #"a\.b\([^()]*\)(?=;)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
a.b();
a.b(param1=1);
a.b(param1=1, param2=2);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\g<0>.c()"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)