package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)interface (\S+)[^!]+?access-session port-control force-authorized`)
var str = `interface GigabitEthernet1/0/44
access-session port-control auto
!
interface GigabitEthernet1/0/45
access-session port-control force-authorized
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}