#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<a href="(?!:images\/|\.\.\/|#|http:\/\/)(.*?)\.html">"
Local $sString = "<a href="word-word-word.html">"
Local $sSubst = "<a href="prefix-$1.html">"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)