using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a href=""(?!:images\/|\.\.\/|#|http:\/\/)(.*?)\.html"">";
string substitution = @"<a href=""prefix-$1.html"">";
string input = @"<a href=""word-word-word.html"">";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}