package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9.]+)`)
var str = `<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html><head>
<META content="text/html; charset=utf-8" http-equiv="Content-Type">
</head><body>
<html>
<body>
[23]
</body>
</html>
</body></html>`
var substitution = "23"
fmt.Println(re.ReplaceAllString(str, substitution))
}