using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-[^-]*$|:[^:\n]*$";
string substitution = @"";
string input = @"ABCDEF
FEDCBA:XA
AA-BB-CCCC-01
AA-BB-CCCC-21:ABC
ABCDEFGH-IJK-1X";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}