$re = '/-[^-]*$|:[^:\n]*$/m';
$str = 'ABCDEF
FEDCBA:XA
AA-BB-CCCC-01
AA-BB-CCCC-21:ABC
ABCDEFGH-IJK-1X';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;