import Foundation
let pattern = #"-[^-]*$|:[^:\n]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ABCDEF
FEDCBA:XA
AA-BB-CCCC-01
AA-BB-CCCC-21:ABC
ABCDEFGH-IJK-1X
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)