$re = '/^(?!.*centrifugo).*xxx/m';
$str = '123 centrifugo 551 xxx
451 abcd xxx 334
yyyy xxx 231';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);