package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([-+*\x{2022}\x{2023}\x{2043}])(?:\s+|$)`)
var str = `* Lorem
* Lorem
* Lorem
* Lorem
*
+ Lorem
- Dolor
• Sit
‣ Lorem
⁃ Ipsum
*No Match
o No Match
0 No Match
? No Match
\` No Match`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}