import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<p\\>[^—].+\\<\\/p\\>";
final String string = "<p>Fără să comenteze, Sam mi-a dat paharul cu vin</p>\n"
+ "<p>– pe care l-am examinat atentă, pentru a fi sigură</p>\n"
+ "<p>că e perfect curat – şi am pornit spre masa</p>\n"
+ "<p>vampirului.</p>\n"
+ "<p>— Vinul dumneavoastră, domnule, i-am spus</p>\n"
+ "<p>protocolar, aşezând paharul pe masă, exact în faţa</p>\n"
+ "<p>lui.</p>\n"
+ "<p>El m-a privit din nou, iar eu n-am scăpat ocazia</p>\n"
+ "<p>de a mă uita fix în ochii lui încântători.</p>\n"
+ "<p>— Să-l beţi cu poftă, i-am zis, mândră.</p>\n"
+ "<p>Moment în care Mack Rattray a strigat în</p>\n"
+ "<p>spatele meu:</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}