using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?[\\\/]src[\\\/]|([\\\/])";
string substitution = @"\\";
string input = @"/home/me/projects/project/src/Commands/Interfaces/Whatever
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}