re = /.*?(word1 word2 word3).*?\/\/\/.*?(?(1)\1)/m
str = 'word1 word2 word3 /// word1 word2 word
word1 word2 word3 /// word1 word2 word3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end