$re = '/((\w;)+\w)\n-{3,}\n((?1)\n)+(?1)/';
$str = 'H;e;l;a;a
---------
J;a;c;k;p
c;d;e;d;c
f;d;e;c;d
k;d;c;d;s
d;e;f;d;e';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;