using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:value[^v]*value=\"")([^\""]*)";
string input = @"<input type=""hidden"" name=""loginForm_SUBMIT"" value=""1"" /><input type=""hidden"" name=""faces.ViewState"" id=""faces.ViewState"" value=""9uiY/UWJ1/w3PQ=="" /></form>
</body>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}