import Foundation
let pattern = ##"(:(?![\n])[()#$@-\w]+:)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
:any-non-whitespace:
:text1:sample2:
:@(1@#$@SD: :s:
:nospace::inbetween: because there are 2 colons in the middle
:nospace:middle:nospace:
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)