$re = '/(?m)\s+(?=[^()]*(\([^()]*(?1)?[^()]*\))*[^()]*$)/';
$str = 'aa b+b cc(dd! :(ee ((f(f g)g)) h)h) ii ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);