import Foundation
let pattern = #"[\d]{1,3}\.[\d]{1,3}\.[\d]{1,3}\.[\d]{1,3}:[\d]{2,5}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<html>
<head></head>
<body>
<pre>
000.000.000.000:0000
000.00.00.000:0000
200.000.000.000:0000
256.000.000.000:00000
192.000.00.000:0000
45.00.0.000:0000
25.00.000.000:00000
255.00.000.00:00000
000.000.000.000:00000
000.000.000.00:00000
000.000.000.000:0000
000.00.000.000:0000
00.00.000.00:00000
000.00.000.000:0000
000.000.00.00:00000
000.00.000.000:0000
00.0.00.000:00000
000.000.00.00:0000
00.0.000.000:00000
000.00.00.00:0000
000.000.000.000:0000
000.00.000.000:00000
000.000.000.000:0000
000.000.00.000:0000
000.00.00.00:00000
00.00.00.0:0000
000.00.000.000:0000
00.000.00.00:00000
000.000.00.0:00000
00.00.000.00:0000
000.000.000.000:0000
00.00.00.0:0000
00.00.000.00:00000
000.000.000.00:0000
00.000.000.00:0000
000.00.00.000:0000
000.00.000.000:0000
000.000.000.00:0000
000.000.00.00:0000
000.00.000.000:0000
000.000.000.000:00000
00.000.00.00:00000
00.000.000.000:00000
00.000.000.000:0000
00.00.00.000:0000
00.00.000.00:00000
00.000.000.000:00000
00.00.00.000:0000
00.000.000.00:0000
000.000.000.000:0000
000.00.000.000:0000
00.00.00.000:0000
00.000.0.000:0000
000.000.000.00:0000
000.000.000.000:0000
00.00.000.000:00000
000.000.000.000:0000
000.00.00.000:00000
00.00.00.000:00000
000.000.000.00:0000
000.000.000.00:0000
00.000.0.00:0000
000.000.00.000:00000
00.000.000.000:00000
00.00.00.000:00000
000.0.000.000:00
000.00.000.000:0000
00.00.000.000:0000
000.00.000.00:00000
000.00.000.0:0000
000.000.00.000:0000
00.00.000.000:0000
00.00.00.000:0000
000.000.000.000:00000
000.000.000.0:00000
000.000.000.000:0000
00.000.000.00:00000
000.00.000.000:0000
000.000.000.000:0000
000.000.000.0:0000
000.000.00.000:0000
000.00.000.000:0000
000.000.000.000:0000
000.000.000.00:0000
00.000.000.000:0000
000.00.000.00:0000
00.00.000.000:0000
000.00.000.000:00000
000.00.000.00:0000
000.00.000.000:0000
000.000.000.0:0000
000.000.000.00:00000
00.000.000.000:00000
00.000.00.0:0000
000.00.000.00:00000
000.00.00.000:0000
000.000.00.000:0000
00.00.000.00:0000
000.00.00.000:0000
000.000.00.00:00000
000.000.00.000:0000
000.000.000.000:0000
000.000.00.000:0000
000.000.000.000:00000
00.000.00.000:00000
00.00.00.0:0000
000.00.000.00:00
000.000.000.00:0000
000.00.00.000:0000
000.000.000.000:00000
00.000.000.00:0000
000.000.000.000:0000
000.000.000.000:0000
00.00.00.000:0000
00.00.00.000:00000
000.000.00.00:0000
000.00.000.000:00000
00.00.000.00:00000
00.000.0.000:0000
000.000.000.000:0000
00.000.00.0:00000
00.00.000.00:0000
000.000.000.0:0000
000.00.000.00:00000
000.0.000.000:0000
000.00.000.0:00000
000.000.000.00:0000
000.00.00.00:00000
000.000.000.000:0000
00.000.000.000:0000
000.00.000.00:0000
000.00.000.000:0000
000.00.000.000:0000
00.00.00.0:0000
00.0.000.000:00000
00.000.000.000:00000
00.00.000.00:00000
000.000.00.00:0000
00.00.000.00:00000
000.000.000.00:0000
000.000.000.000:0000
000.00.000.000:0000
00.000.00.00:00000
000.000.000.000:0000
000.000.00.000:0000
000.000.000.000:0000
000.000.000.000:00000
00.000.00.0:0000
000.000.000.00:0000
00.00.000.00:0000
00.00.00.00:0000
000.000.000.00:0000
000.00.000.00:0000
000.00.000.00:0000
000.00.000.00:0000
00.00.00.00:0000
00.00.00.00:0000
000.000.000.00:0000
000.000.000.000:0000
000.000.00.000:00000
0.00.000.00:00000
000.00.00.00:00000
000.00.000.000:0000
00.000.00.00:00000
000.00.0.000:0000
00.000.00.000:00000
00.000.000.000:00000
000.00.00.000:0000
000.000.00.00:00000
000.000.00.00:0000
00.000.000.000:00000
000.00.000.00:0000
000.00.000.00:0000
00.00.000.00:0000
00.000.00.0:0000
00.00.00.00:0000
00.000.00.00:00000
00.000.000.00:00000
00.000.00.000:00000
0.00.00.00:0000
000.000.000.000:0000
00.000.000.00:00000
000.00.00.000:0000
000.000.000.00:0000
000.000.00.00:0000
000.000.000.000:0000
000.00.000.0:00000
000.000.000.000:0000
000.000.000.00:0000
00.000.00.0:0000
000.000.00.000:0000
000.000.000.000:00000
00.00.000.000:0000
000.00.0.00:0000
000.00.00.000:0000
000.000.00.000:00000
000.000.00.000:00000
00.0.00.00:00000
000.00.000.00:0000
00.000.000.000:00000
000.000.000.00:0000
00.00.000.00:00000
00.000.000.000:0000
00.00.000.00:00000
00.0.00.000:00000
000.000.000.000:0000
00.00.000.00:00000
000.00.000.00:00000
00.00.00.000:0000
000.00.000.000:0000
000.000.000.00:0000
000.00.00.00:0000
00.000.00.00:00000
00.00.000.00:00000
000.000.000.000:0000
000.000.000.000:0000
00.000.00.00:0000
00.000.00.000:00000
000.00.00.00:00000
000.00.000.000:0000
000.00.000.00:00000
000.00.000.0:00000
000.000.000.000:00000
000.000.000.000:00000
00.000.000.00:00000
00.000.000.00:00000
00.000.000.000:00000
00.000.00.00:0000
000.000.000.000:00
00.00.000.00:0000
00.000.00.00:00000
000.0.000.000:0000
00.000.00.000:00000
00.00.00.00:0000
000.00.000.00:00000
000.00.000.000:0000
000.000.00.00:00000
000.000.000.0:00000
000.00.000.00:00000
000.000.000.000:0000
000.00.00.000:00000
000.00.00.00:00000
000.000.000.00:00000
000.00.00.00:0000
00.00.00.000:0000
000.00.000.000:0000
000.000.00.00:00000
000.000.000.00:0000
000.00.000.000:00000
000.000.00.00:0000
000.000.000.0:0000
000.000.00.000:0000
000.000.000.000:00000
00.000.000.000:00000
000.00.000.00:00000
00.00.00.000:0000
00.00.000.000:0000
000.000.000.00:00000
000.000.00.000:00000
00.000.000.00:0000
000.000.00.000:0000
000.000.00.000:0000
000.000.000.00:0000
000.000.000.000:00000
00.000.000.00:00000
000.000.00.000:00000
000.000.00.000:00000
000.000.000.000:0000
000.00.00.00:0000
000.000.00.00:00000
00.000.0.00:0000
000.00.00.000:00000
000.000.000.00:0000
000.000.00.00:0000
00.00.000.00:0000
000.00.000.00:00000
000.00.00.00:00000
00.00.000.000:00000
00.00.000.000:00000
000.000.000.00:0000
00.00.000.000:0000
000.000.000.00:0000
000.000.000.000:0000
00.00.00.000:0000
000.00.00.000:0000
000.000.000.00:0000
000.000.000.000:0000
00.000.00.000:0000
00.0.000.00:00000
000.000.00.000:0000
000.000.00.00:00000
000.00.000.00:00000
000.00.000.00:0000
000.00.000.000:0000
000.00.000.00:00000
00.00.00.0:0000
000.000.00.00:0000
000.00.00.000:00000
00.000.000.000:00000
000.00.000.000:0000
000.00.00.000:0000
00.000.000.000:00000
000.000.00.000:0000
00.00.000.000:00000
000.000.000.00:00000
000.00.00.00:0000
000.00.00.00:00000
00.00.00.0:0000
00.00.000.000:00000
000.00.00.00:00000
00.000.000.00:0000
000.000.00.00:00000
000.00.00.00:00000
000.000.000.000:00000
00.000.000.00:0000
000.000.0.000:0000
00.00.000.000:0000
000.00.00.00:0000
00.00.00.000:0000
000.00.000.000:0000
000.00.00.000:0000
00.00.00.000:0000
00.00.000.000:0000
00.000.000.000:00000
000.00.00.00:0000
000.000.00.000:00000
00.00.000.000:0000
000.000.000.000:0000
00.00.00.0:0000
00.000.000.000:0000
000.00.000.000:00000
00.0.000.000:00000
000.00.000.000:0000
000.00.00.00:0000
000.000.000.0:0000
00.00.000.00:0000
00.00.000.00:0000
000.000.000.0:00000
000.00.00.000:0000
000.00.000.000:0000
000.00.00.00:00000
000.00.000.000:0000
00.00.00.000:0000
000.000.000.000:0000
000.00.000.00:0000
00.00.00.000:0000
000.00.00.00:00000
000.000.000.000:0000
000.000.00.00:00000
000.000.00.00:0000
000.000.000.000:0000
000.00.00.000:0000
000.000.000.00:0000
00.00.00.000:0000
00.000.000.000:0000
00.000.00.00:0000
000.000.00.000:0000
000.00.000.00:00000
000.00.000.00:0000
000.00.000.0:0000
00.000.000.000:00000
000.000.000.00:00000
000.000.000.000:0000
000.000.000.000:0000
000.000.00.000:0000
00.000.000.000:00000
000.000.000.00:0000
000.00.000.00:00000
000.00.00.000:0000
00.00.000.00:00000
00.000.000.000:0000
000.000.000.000:0000
000.000.000.00:00000
00.000.00.0:0000
000.00.000.000:0000
000.000.00.000:00000
00.00.00.000:0000
00.000.000.00:0000
000.00.00.000:00000
000.000.000.0:0000
000.000.0.00:0000
000.000.00.000:0000
0.000.000.000:0000
00.0.00.00:00000
000.000.000.000:0000
00.0.0.000:00000
00.000.00.000:00000
00.00.00.000:00000
000.000.00.000:0000
000.00.00.000:0000
000.00.000.000:0000
000.00.000.00:0000
00.000.00.00:0000
00.00.00.00:0000
000.00.00.00:00000
00.00.00.000:00000
000.00.00.000:00000
000.00.000.000:0000
00.000.000.00:00000
00.000.00.000:00000
00.00.000.00:00000
000.000.00.000:00000
000.00.000.00:0000
000.000.00.000:0000
000.000.00.000:0000
00.000.00.000:0000
000.00.00.00:00000
000.000.000.00:00000
000.000.000.000:0000
000.00.000.000:00000
000.000.000.000:0000
000.000.000.00:0000
000.000.000.00:0000
000.000.000.00:0000
000.00.000.000:0000
000.000.000.000:0000
000.000.00.000:0000
000.0.00.00:00000
000.00.00.00:00000
000.00.000.000:0000
000.000.000.00:0000
000.000.000.000:0000
000.000.000.00:00000
000.000.00.000:0000
000.00.00.00:0000
000.000.00.000:0000
00.00.00.000:0000
000.000.00.000:0000
00.000.000.000:0000
00.000.00.00:00000
000.000.000.00:00000
000.000.00.000:00000
00.00.00.00:0000
000.000.000.000:0000
000.000.000.000:0000
000.00.000.0:0000
000.000.00.000:0000
00.00.00.000:00000
00.000.0.000:0000
00.00.00.000:0000
00.000.00.000:0000
0.00.000.00:0000
00.000.000.00:00000
00.000.00.000:00000
000.000.00.000:0000
00.00.000.00:0000
000.000.000.000:00000
000.00.00.00:00000
00.000.00.00:0000
000.00.000.00:0000
00.000.00.000:0000
00.000.00.00:0000
000.000.000.00:0000
000.000.0.00:0000
00.000.000.000:0000
00.00.000.000:0000
000.00.000.000:0000
000.000.000.00:0000
000.00.000.000:0000
00.000.00.00:0000
000.00.000.000:0000
00.000.000.000:00000
000.00.00.000:00000
000.00.00.000:00000
000.000.000.000:0000
000.00.000.0:0000
000.000.00.0:0000
000.000.00.00:00000
000.00.00.00:00000
000.00.00.000:00000
00.00.00.000:00000
00.00.000.00:0000
00.000.00.000:0000
000.00.00.00:0000
00.00.000.000:00000
00.000.000.00:00000
000.00.000.0:0000
000.000.00.000:0000
000.000.000.000:0000
000.00.000.000:00000
000.00.00.00:00000
000.000.000.00:00000
000.00.00.00:00000
00.000.000.000:0000
000.00.000.000:0000
000.000.00.00:0000
00.000.000.00:0000
00.000.00.00:0000
00.000.00.00:00000
000.00.000.000:0000
000.000.00.000:00000
000.00.000.000:00000
000.00.000.000:0000
000.00.0.00:00000
000.00.00.000:0000
0.000.00.00:00000
000.00.000.00:00000
000.000.00.000:0000
000.0.000.000:00000
00.000.00.000:0000
000.000.00.00:0000
00.000.000.00:00000
000.000.000.000:00000
00.000.000.000:00000
000.000.00.000:0000
000.000.00.000:0000
00.000.000.00:0000
000.00.00.00:00000
000.00.000.000:0000
000.00.000.000:0000
00.000.000.000:0000
000.000.000.0:0000
000.00.000.000:0000
00.000.00.000:0000
000.00.000.000:0000
000.000.000.0:0000
000.000.000.00:0000
000.000.000.000:0000
000.000.00.00:00000
000.00.00.00:00000
00.000.00.00:0000
00.00.00.00:0000
000.00.000.00:0000
000.000.000.000:0000
000.00.000.00:00000
00.000.00.0:0000
00.000.000.00:0000
000.00.000.00:00000
000.00.000.00:0000
00.00.000.00:0000
000.00.000.000:0000
000.000.0.00:00000
000.000.00.000:0000
000.00.00.000:00000
000.000.000.000:0000
000.00.000.000:0000
000.000.000.00:00000
000.000.000.000:00000
000.000.000.000:0000
000.000.00.00:0000
00.000.000.00:00000
000.00.00.000:00000
000.00.000.00:00000
00.000.00.00:0000
000.000.000.00:0000
000.00.000.000:0000
000.00.000.00:0000
000.000.000.00:00000
000.00.00.00:0000
000.000.000.00:0000
000.0.000.00:00000
000.000.00.00:0000
000.000.0.000:00000
000.000.00.000:0000
000.000.00.00:00000
00.000.000.00:0000
00.0.00.0:00000
00.0.00.000:00000
00.00.00.000:0000
000.00.00.00:0000
000.000.00.00:0000
00.00.000.000:00000
000.00.000.000:00000
00.000.0.000:00000
000.00.000.00:00
000.000.000.000:0000
000.000.00.000:0000
00.00.00.000:00000
00.00.000.000:0000
000.000.0.000:000
00.000.000.00:00000
00.000.000.000:0000
00.00.00.00:0000
000.000.00.00:00000
000.000.00.000:00000
000.000.000.000:00000
00.000.00.000:0000
00.00.00.000:00000
00.000.00.000:00000
000.000.00.00:0000
000.000.000.000:0000
000.000.00.000:0000
000.000.000.00:0000
00.000.00.000:0000
000.00.0.000:0000
000.000.000.00:0000
000.000.000.000:0000
000.000.00.000:0000
00.000.00.000:0000
000.000.000.000:0000
000.00.000.00:0000
00.0.00.00:0000
000.000.000.000:0000
000.00.000.000:0000
000.000.00.000:0000
000.000.000.00:00000
00.000.000.00:00000
000.00.000.00:0000
00.00.00.000:00000
000.000.000.00:0000
00.000.00.000:0000
000.000.000.000:00
00.000.000.00:00000
000.0.000.000:0000
000.00.000.000:0000
000.000.00.00:00000
000.00.000.000:0000
00.000.000.00:0000
000.000.00.000:0000
000.000.000.00:00000
000.00.000.000:0000
000.00.000.0:00000
00.00.000.000:0000
00.000.00.00:0000
000.000.000.000:00000
000.000.00.00:0000
00.000.00.000:0000
00.000.00.00:0000
000.00.000.000:0000
000.000.000.000:0000
0.00.000.000:0000
000.000.00.00:00000
000.000.00.000:0000
00.000.00.000:0000
00.00.000.00:00000
00.000.00.00:0000
000.00.000.000:0000
000.00.00.00:0000
00.000.000.000:00000
00.00.00.000:0000
00.00.000.000:0000
0.0.000.00:0000
0.000.00.000:0000
000.000.000.000:0000
00.0.000.000:00000
00.00.00.00:00000
000.000.000.000:00000
000.00.000.00:00000
000.00.00.000:0000
00.000.000.000:0000
000.00.000.00:00000
00.00.00.000:0000
000.00.00.000:0000
000.000.000.000:0000
000.000.0.00:0000
000.000.00.00:0000
000.000.000.00:0000
000.00.000.000:0000
000.000.000.00:0000
00.000.00.00:0000
00.000.00.00:0000
000.000.000.000:0000
000.000.000.000:0000
000.000.000.000:0000
000.000.00.000:0000
00.000.000.000:0000
000.000.000.000:0000
000.00.00.00:0000
00.00.00.000:0000
00.00.00.00:00000
000.000.000.00:0000
000.00.000.000:0000
00.00.000.000:00000
000.000.00.0:0000
00.00.00.000:0000
000.00.000.00:00000
000.000.000.000:00000
00.000.000.000:00000
00.000.0.000:00000
000.000.000.000:0000
000.00.000.00:0000
00.00.00.00:0000
000.000.000.00:0000
000.000.000.00:00000
000.00.00.00:0000
000.00.0.00:0000
00.00.000.000:00000
00.00.000.00:0000
000.000.000.000:00000
000.000.00.000:00000
00.000.000.000:0000
000.000.00.000:00000
00.000.000.000:0000
000.00.000.00:0000
000.00.000.00:00000
00.000.000.000:0000
000.0.00.000:00000
000.00.00.000:00000
00.00.000.000:0000
000.00.000.00:0000
000.000.000.00:0000
000.000.000.000:00000
000.00.00.00:0000
000.00.000.000:0000
000.00.0.000:0000
000.000.000.000:00000
000.00.000.00:0000
00.000.000.00:0000
00.000.000.000:00000
000.00.000.00:0000
000.000.00.00:00000
000.000.000.000:0000
000.00.00.000:0000
00.0.00.00:00000
000.000.000.000:0000
000.00.000.000:0000
00.00.000.00:0000
000.000.00.00:00000
000.000.00.00:0000
00.000.000.00:0000
00.000.000.00:0000
000.000.00.000:00000
00.0.00.000:00000
000.00.00.000:00000
00.00.000.000:0000
00.000.000.00:0000
00.000.00.000:0000
000.000.000.00:00000
000.00.000.000:00000
00.000.00.00:0000
000.000.00.000:0000
000.000.00.000:0000
000.00.0.00:0000
0.0.000.000:00000
000.0.000.000:0000
000.000.00.000:00000
00.000.000.000:00000
00.000.000.000:0000
000.00.000.000:00000
00.000.00.00:00000
00.000.000.00:00000
000.00.00.00:00000
00.000.000.00:0000
000.000.000.000:0000
00.0.00.00:00000
000.00.000.000:0000
00.000.000.00:0000
00.000.0.00:0000
00.000.000.000:0000
000.000.000.000:00000
000.00.00.000:0000
00.00.00.000:0000
000.000.000.000:0000
00.0.00.000:0000
00.00.000.000:0000
00.0.00.000:00000
000.00.000.00:00000
000.000.000.00:0000
000.000.00.00:0000
00.000.000.0:0000
000.00.000.000:0000
000.000.00.000:0000
000.000.00.00:0000
00.000.00.00:0000
000.00.000.00:0000
00.000.00.000:0000
00.000.00.000:0000
000.00.000.0:0000
000.000.00.00:00000
000.000.000.000:0000
00.000.000.00:00000
00.000.000.0:0000
00.00.000.00:0000
000.000.00.00:0000
000.000.000.000:0000
00.00.000.00:0000
000.000.00.000:0000
000.000.00.000:00000
000.00.000.00:0000
000.000.00.00:0000
00.00.000.000:0000
000.00.00.000:0000
000.00.000.000:0000
00.000.000.000:00000
000.00.000.00:00000
000.0.000.000:0000
00.000.000.00:0000
00.00.00.000:0000
000.00.000.00:00000
000.00.000.0:0000
000.00.000.000:00000
00.000.000.000:0000
00.000.000.000:0000
000.00.00.00:0000
000.0.000.000:0000
000.000.000.000:00000
000.00.000.000:0000
00.00.00.000:0000
000.000.000.000:00000
00.0.00.000:00000
000.000.000.000:00000
000.000.000.000:00000
000.000.000.00:0000
000.00.00.000:0000
00.00.00.000:0000
00.000.000.000:0000
00.000.00.00:0000
000.00.00.000:00000
0.00.000.000:0000
000.000.00.00:0000
000.000.00.00:0000
000.00.000.000:0000
000.00.000.000:0000
000.00.00.00:0000
00.00.00.000:0000
00.000.000.00:00
000.00.000.0:0000
000.000.00.00:0000
000.00.000.0:0000
000.000.00.00:0000
000.00.00.000:00000
00.000.00.000:00000
00.000.00.00:0000
00.000.000.000:0000
000.000.00.000:0000
000.000.000.00:00000
00.00.00.000:0000
00.0.00.00:00000
000.000.000.00:00000
000.000.000.000:0000
000.000.000.000:0000
000.00.000.0:00000
000.000.00.000:0000
00.000.000.00:0000
000.000.00.000:00000
000.000.0.00:00000
000.000.000.000:0000
00.000.00.000:00000
00.000.00.000:00000
00.00.00.00:0000
000.00.000.000:0000
00.00.00.000:0000
00.000.000.00:00000
000.00.00.000:00000
000.00.00.00:00000
00.000.0.0:00000
000.000.000.000:0000
00.000.000.0:00000
000.00.000.00:0000
000.00.00.000:00000
000.000.00.000:0000
00.00.00.0:0000
00.00.000.00:00000
00.00.00.000:00000
00.000.00.000:00000
000.00.000.000:00000
00.000.00.00:00000
00.00.00.000:00000
000.00.000.00:00000
000.00.00.000:00000
000.000.000.000:0000
000.00.000.000:0000
000.00.000.000:0000
000.000.000.00:00000
000.00.00.00:00000
00.000.000.000:0000
000.000.00.000:0000
000.00.000.000:00000
000.000.00.000:00000
00.000.00.00:00000
000.000.000.000:0000
000.000.0.00:00000
00.000.000.00:00000
000.00.00.000:00000
000.000.000.000:0000
00.000.00.000:00000
000.000.00.00:0000
00.000.000.00:0000
00.000.000.000:00000
000.00.00.000:00000
000.00.00.0:00000
000.00.00.00:00000
000.000.00.00:0000
000.000.000.00:0000
00.00.000.00:00000
000.00.00.00:00000
000.000.000.00:00000
000.000.00.00:00000
00.000.000.00:00000
000.000.000.00:0000
000.000.000.00:0000
00.00.00.000:0000
000.00.000.00:0000
00.000.00.00:00000
00.000.000.000:00000
000.000.000.000:0000
000.000.000.00:0000
00.0.000.000:00000
000.000.000.00:00000
00.000.000.000:00000
000.000.000.00:0000
00.00.00.00:0000
00.000.000.000:00000
00.000.00.000:00000
000.00.00.00:00000
000.000.000.000:0000
00.00.00.0:0000
00.0.0.000:00000
000.00.0.00:0000
00.00.00.00:00000
000.00.000.00:0000
000.00.00.00:0000
000.000.000.000:0000
000.00.00.000:00000
000.000.00.000:00000
000.000.000.00:0000
00.000.000.000:00000
00.000.00.000:00000
000.00.000.000:00000
000.000.000.0:00000
00.00.00.00:0000
00.000.000.000:00000
000.000.000.000:00000
000.000.00.00:0000
00.00.000.000:00000
000.00.00.000:00000
000.000.000.000:0000
00.00.00.00:00000
000.000.000.0:0000
000.000.000.000:0000
000.000.000.000:0000
</pre>
</body>
</html>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)