use strict;
my $str = '_AA_AA_AA_BB_BB_CC';
my $regex = qr/(.)_\1/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";